Constant Contact Connection Error

Incident Report for Buildout

Resolved

This incident has been resolved.
Posted Nov 22, 2023 - 13:31 CST

Investigating

We are aware of reports from some users that they are not able to connect to and send emails with Constant Contact. Our team is working to resolve this as quickly as possible!
Posted Nov 21, 2023 - 16:11 CST
This incident affected: Buildout (Buildout.com).